东莞长安淘宝培训,东莞网络营销培训就选实战派小郭 - 生活趣事 /东莞长安哪里淘宝培训 - RainbowSoft Studio Z-Blog 1.8 Walle Build 100427zh-CNCopyright gdhaoyou.com. Some Rights Reserved.Sat, 28 May 2022 05:52:58 +0800客户硬盘500G变为8G,数据丢失,看我如何帮他找回数据 guoguilin88@163.com (admin)/post/yingpan.htmlFri, 06 Dec 2013 09:57:10 +0800/post/yingpan.html为什么会这样呢?:如果是移动硬盘H,这其实是移动硬盘的常见问题,起因是“由于移动硬盘的热插拔引起的......”
平时我们会遇到这样的情况,安装在E盘的软件无法正常使用(或移动硬盘H显示目录或文件损坏,无法打开访问),有时一旦访问该分区系统就提示需要格式化。

检查发现该分区已经变成了RAW格式,而且已用空间和可用空间都显示为0字节,这就代表着里面的数据已经全部消失。遇到这种情况,千万不要选择格式化该分区,因为这时分区中的数据并没有被清除,只是暂时不能访问。既然是分区格式问题用分区修复软件来解决这个问题,采用《易我分区表医生 V3.0》就能够解决,让分区格式恢复为正常的FAT32,并且数据也能够正常的存取。第一步:启动易我分区表医生V3.0后(图2),选择“分区→检查分区”,软件就会提示要E盘(或底硬盘,即移动硬盘H)进行修复操作,回答“是”就可以将它恢复为FAT32格式并且能够查看里面的文件了。

第二步:如果选择“检查分区”这样的自动操作都无法修复,那就选择交互修复,因为易我分区表医生V3.0修复引导是它的主要功能。

只要选择“操作→修复引导”或直接按F8键,然后软件就会对需要修复的分区进行检查,并且在弹出的对话框中选择“是”来进行修复。

重要提醒(warning):

1.分区变为RAW格式并不可怕,关键在于不要格式化该分区。如果选择了格式化,那就是将数据消除了。

2.这样就可以解决分区变为RAW格式的问题,并且数据没有受到任何损坏。
  下次再遇到RAW格式的分区时,就有办法能够恢复了。

3.如果是C盘变为RAW格式可以选择在D盘安装一个Windows XP操作系统,然后利用该软件来进行恢复。
 

《易我分区表医生》是一款修复硬盘分区的软件,使用该工具可以轻易的恢复删除和丢失的分区。当你的驱动器发生错误(不是硬件错误)时,这个工具能自动的检查并且修复你的MBR、分区表和分区的引导扇区错误,能恢复IDE/ATA/SATA/SCSI接口的硬盘上的FAT16/FAT32/NTFS/ NTFS5/EXT2/EXT3/SWAP等文件系统。如果你的操作系统不能正常启动,你可以创建该软件的紧急启动盘或可启动光盘。

]]>
生活趣事/post/yingpan.html#comment//feed.asp?cmt=467/cmd.asp?act=tb&id=467&key=65b5451d
有多少人知道其实网盘是可以赚钱的? guoguilin88@163.com (admin)/post/wangpan.htmlMon, 11 Nov 2013 17:30:30 +0800/post/wangpan.html有多少人知道其实网盘是可以赚钱的?很多人不明白去下载一个文件,弹出广告一堆,为什么这些人不找个好点的网盘,没有广告的网盘?其实是有利益链条在这个里面的。市面上的网盘多如牛毛,慢慢挑的话恐怕会挑花了眼!各种网盘之间都有不同的自身优势以及对比出来的劣势!印象中若干年前有永硕、F2YOU、纳米盘 之类的;江湖硝烟四起,雨林木风横空出世115网盘,傲视群雄!而近来115网盘的几次大动作让很多网友吐槽!必须绑定手机,15G空间……

反观百度网盘,对于容量是木有限制的;所以我已经把115网盘里的资源全部转移至百度网盘,当然我收藏的大多数是软件以及文档类资料,容量不大,转移很比较快。而影视类论坛所采用的网盘就要麻烦了,转移也更难了,所以近来很多影视论坛都在补档。

又扯远了,今天的主题是网赚类网盘,网赚类网盘主要以点击计费或下载计费为主。
以某个网盘为例(避免广告嫌疑,隐去名字)。
我们有以下几个特点,让您赚得更多:
点入下载页,即计入您的收益,无需完整下载。
我们支持下线用户,轻松赚提成。
我们将持续永久地支付您 20% 下线下载收入提成。
收入满20元即可申请提现,每周一结算上周所有申请。

于是在一些论坛,特别是中小型论坛,一些会员通过这类网赚网盘来分享资源,特别是分享一些擦边球资源,例如美女写真、内衣展览等,这类资源市场需求 很大,下载人数之多,而分享者收益很快便增长不少,这样的情况对于管理员来说其实是双赢的局面,发帖者有收益便有发帖动力,帖子多会员回帖也多,说不定还 能参与讨论;对于论坛前期发展是有利的,当然后期就另说了。

网赚网盘在一些大型论坛是不允许出现的,哪怕类似于百度网盘邀请(邀请者与被邀请者都有网盘容量奖励)都不允许发的,我也不明白为什么这种“双赢” 的事情是被禁止的,原因仅仅就是“能给个人带来利益”嚒?中国有句古话叫做“莫挡人财路”,或许每个地方有每个地方的规矩,不管怎样需遵守游戏规则!

其实网赚类网盘在18倒是很常见,典型的就是SIS,在SIS的原创区很常见,例如片子的预览图所在的图床每次点击都会有一些费用的,包括放种子的网盘亦是如此!而且都是一些国外网盘,点击计费都是以美元来计算的……我想这也是发片人发片的动力之一吧~

网赚网盘也有不足的地方,通常这类网盘下载速度不是很快,下载页面广告较多,提现需要达到一定的额度,网赚之路漫漫长,网赚客坚持才是硬道理!

]]>
生活趣事/post/wangpan.html#comment//feed.asp?cmt=460/cmd.asp?act=tb&id=460&key=6b771732
changeip的DDNS一直是个头痛的问题,今天没事就写了个程序! guoguilin88@163.com (admin)/post/ddns.htmlWed, 16 Oct 2013 08:58:06 +0800/post/ddns.htmlchangeip的DDNS一直是个头痛的问题,今天没事就写了个程序!

:local new
:global status
:global new1

:set status [/interface get [/interface find name=pppoe-out1] running]
:if ($status=true) do={
     :set new [/ip address get [/ip address find dynamic=yes interface=pppoe-out1] address]
     :set new [:pick $new 0 ([:len $new] -3)]
     /tool dns-update address=$new key-name=ggm1 key=81 name=ggm.changeip.name
} else{
     :set new1 [/ip address get [/ip address find dynamic=yes interface=pppoe-out2] address]
     :set new1 [:pick $new1 0 ([:len $new1] -3)]
     /tool dns-update address=$new1 key-name=ggm1 key=81 name=ggm.changeip.name
}

要读懂语句的哦!

:local new                这句的意思是,定义new这个变量
:global status              这句的意思是定义status这个变量
:global new1                这句的意思是,定义new这个变量

:set status [/interface get [/interface find name=pppoe-out1] running]   这句的意思是,判断pppoe-out1这个连接的状态,是否为true,也就是说,有没有正常联网。
:if ($status=true) do={                                                               这句的意思是,如果是true的,也就是说联上网的,那么就运行下面的脚本
     :set new [/ip address get [/ip address find dynamic=yes interface=pppoe-out1] address]               这句的意思是,将pppoe-out1这个连接的IP地址的值 赋给 new这个变量
     :set new [:pick $new 0 ([:len $new] -3)]                                                            这句的意思是,将new这个变量,的最后三位字母去掉,重新赋给new这个变量 ( 因为上一句获得的IP地址是这样的:xxx.xxx.xxx.xx/24 我们要把/24去掉,就用这一句)
     /tool dns-update address=$new key-name=用户名 key=密码 name=域名                               这一句,就是将new变量中的IP地址,填入到,这一句更新的DNS命令中去。
}
:else={                                                            这句的意思是,如果是true的,也就是说联上网的,那么就运行下面的脚本
     :set new1 [/ip address get [/ip address find dynamic=yes interface=pppoe-out2] address]               这句的意思是,将pppoe-out1这个连接的IP地址的值 赋给 new这个变量
     :set new1 [:pick $new 0 ([:len $new] -3)]                                                            这句的意思是,将new这个变量,的最后三位字母去掉,重新赋给new这个变量 ( 因为上一句获得的IP地址是这样的:xxx.xxx.xxx.xx/24 我们要把/24去掉,就用这一句)
     /tool dns-update address=$new1 key-name=用户名 key=密码 name=域名                               这一句,就是将new变量中的IP地址,填入到,这一句更新的DNS命令中去。
}这样就不用弄2个动态域名了

 

]]>
生活趣事/post/ddns.html#comment//feed.asp?cmt=453/cmd.asp?act=tb&id=453&key=58efe47b
监控员工qq软件,qq聊天监控,企业资料加密,分公司电脑监控软件汇总 guoguilin88@163.com (admin)/post/qqmfjk.htmlTue, 24 Sep 2013 16:38:04 +0800/post/qqmfjk.html首先声明,我们这次是帮朋友推荐的软件的,我们不参与销售,一个兄弟自己做了一款软件,据说反响还不错!我们现在在用他们的软件,还是可以的!

声明:这个是软件的费用,不含安装 ,远程安装配置请联系店家修改价格+20元

软件使用期限:无限制,没有时间限制

一次性注册不搞二次收费,永久使用、正版软件安装、不做第二次编辑、保证软件原版 合理规划公司网络资源分配,管理员工上网行为,更多功能 请在线联系  在线咨询:

提供企业各种管理专业软件  用贴心的服务 服务每一个客户
软件分为局域网版本和外网版本,外网版本需要具备一定的网络环境,请联系店家进行咨询!
很多客户会问:我家里有小孩子上网,我想在公司上班可以监控到小孩子的上网情况还有qq聊天记录等。
那么就可以选择外网版本了!外网版远程协助安装配置,凡是在一周内确认付款并评价的用户将获得提供售后优先权。
软件安装包有详细的安装教程和设置手册,凡是需要提供远程帮忙安装请额外支付20元安装设置费用


局域网管理50元起拍,局域网人数超过50元会按1.5每用户收费!(适合全部电脑在用一根网线,在同一个路由器下面的)


外网管理+内网管理 150元起,用户数超过80人会按1.5每用户收费!(适合总部+分部监控模式,就是监控服务器在总部,监控分部电脑,也就是很多人问的,我在外地想监控公司的员工!相隔几十公里或者跨省)

单独软件价格可能有点混乱,我说下具体的:

30人以下局域网 50元  30-50人局域网 70  50人以上局域网+1.5每人

外网或者外网+内网 50人以下 150元 50人以上需要+1.5每人

模块可以选择定制:也就是你可以要其中的某些模块或者不要某些模块,减少管理工作量! 

屏幕录像查看/ 通讯管理/  U盘管理 /上网管理/ 资产管理  /可额外加/qq聊天监控(局域网加密管理、打印机管理、文件管理)

 解决问题
        1、掌握内部所有电脑的硬件和软件资源,以管理资源设备和重要资料文件;
        2、掌握内部所有电脑安装的运用程序,以防止滥用电脑;
     
        4、禁止对U盘、光盘、文件等的存取;以防止病毒和资源泄露;
        5、实时记录,防止重要资料通过各类工具外泄;
        6、限制各种应用程序的使用,并可制定详细的时间规则,提升工作效率。

        方案阐述:
       
        管理员可以使用控制台查看终端电脑的文件操作日志,打印机日志等,且可以通过设置控制规则,禁止终端电脑的USB设备,软驱,光驱和禁止指定的应用程序等功能。
        终端离开服务端所在局域网,终端程序也会自动保存该电脑的使用记录,并在接回服务端所在局域网时自动将记录上传到服务端供管理员查看。

        系统工作流程

        系统管理员通过控制台给每个终端用户度身定制内网安全策略;
        终端启动时将从服务端获取对应的内网安全策略,并按服务端设置的控制规则生效。
 


 会不会被杀毒软件杀掉?或者被员工卸载掉?
本软件兼容了国内外近20种杀毒软件,包括诺顿、卡巴斯基(Kaspersky)、McAfee、瑞星、江民、金山毒霸、360安全卫士、Nod32、趋势等。安装完监控软件客户端请重启客户端电脑哦

]]>
生活趣事/post/qqmfjk.html#comment//feed.asp?cmt=452/cmd.asp?act=tb&id=452&key=0289cc62
QQ督察聊天监控软件windows 7无法监控2013版本怎么解决? 其他免费QQ监控软件,现在这类软件非常多,比这个功能更完善的也有很多。

 

]]>生活趣事/post/qqjk_5762.html#comment//feed.asp?cmt=449/cmd.asp?act=tb&id=449&key=edf1575b
免费qq监控软件下载,各种聊天监控工具汇总

还有10元一款的家长监控自己孩子的QQ聊天记录软件,同时还可以进行录像操作哦!还有免费软件!

]]>生活趣事/post/qqjk.html#comment//feed.asp?cmt=448/cmd.asp?act=tb&id=448&key=2bdb5b86
ipguard和ViaControl威盾破解安装及破解思路教程 guoguilin88@163.com (admin)/post/ipguard.htmlFri, 09 Aug 2013 11:14:02 +0800/post/ipguard.html先解释一点,ipguard和ViaControl实际上是同一个软件,只不过是开发商改成了2个名字,分开给两个不同的代理商来销售而已。
 威盾 3.50.0918升级到3.50.2923 支持1000用户PJ
经测试稳定可用。
 2012-4-7 12:45:29 上传下载附件 (47.25 KB)

威盾 3.50.2808   是个升级补丁
直接执行
可以  升级客户端    服务器 端     控制台端
升级后原有数据保留
记得先备份原有的0918目录里的
0control3.exe
0server3.exe
升级完毕后把这两个文件拷贝到安装目录里覆盖,然后用通用补丁在破解一次即可


威盾 3.50.2923    是个升级补丁
直接执行
可以  升级客户端    服务器 端     控制台端
升级后原有数据保留
记得先备份原有的0918目录里的
0control3.exe
0server3.exe
升级完毕后把这两个文件拷贝到安装目录里覆盖,然后用通用补丁在破解一次即可

IP-Guard威盾企业信息监管系统包括了基本模块、邮件管控、文档操作管控、文档打印管控、设备管控、即时通讯管控、移动存储控制、网络控制、网络流量管控、网页浏览管控、应用程序管控、屏幕监视、资产管理、远程维护、文档加密等十五个功能模块。

 IP-Guard威盾破解安装教程:

1、禁用外网网卡。安装“ViaControl3.50.0918.exe”。安装过程很简单,不细说,安装之后在右下角停止OServer3服务(右击任务栏的“服务控制器”,选择“停止服务”)。

2、重新启动OServer3服务(右击任务栏的“服务控制器”,选择“启动服务”)。

3、输入1000用户的主序列号。

4、运行“通用破解工具.exe”选软件名称为“威盾” 接着选好版本号:3.50 0918,

然后左边选进程名称“oserver3.exe”点“先点我测试”,提示成功,

再接着左边选进程名称“ocontrol3.exe”点“先点我测试”,提示成功。

5、和上一步骤一样,分别选“oserver3.exe”和“ocontrol3.exe”,分别点读取和修改。

然后点设置,软件名选威盾,版本号选3.500918, 在服务方式和多文件都打上勾。
文件列表的2个文件也必须有勾,最后点执行他会问你是否写入启动项,选是。

6、内存破解完成,

7、屏蔽威盾官网IP和地址。


 IP-Guard威盾破解思路

=======================

好了,我们先来检查所有的部件,看是否齐全
1、“ViaControl3.50.0918.exe” 也就是ipguard3.50 0918原版安装文件一个
2、“破解工具3.50.0918” 破解文件夹
3、“1000用户sn.txt”sn文件,还是要注册的,就用这个注册
4、“startdelay_v2.3b130.exe”调整系统服务的先后顺序,这个很重要。
5、“封锁威盾出外网的批处理.bat”这个是给IPG服务器需要连外网的朋友准备的。
6、“IP-GUARD V3.1数据库清除和备份工具DBCleaner_V3.1”这个也留给需要的朋友
在开始前,写给之前有装过IPG的朋友几句话,把旧的先卸载,不需要关服务控制器,卸载程序会自动关。卸载完后重新启动电脑,然后再进IPG的安装目录,把安装目录给删掉。然后用“IP-GUARD V3.1数据库清除和备份工具DBCleaner_V3.1”清一下ipg残余的数据
现在开始进入安装破解过程,请按步骤一步一步来:
1、先断外网!!这个是必须的。。。然后安装“ViaControl3.50.0918.exe”具体过程不说了,下一步下一步。。。ok。。。。停止OServer3服务,方法:右击任务栏的“服务控制器”,选择“停止服务”
2、打开注册表:HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{578D04C7-7C7D-448A-AF4A-065606069E85},将“{578D04C7-7C7D-448A-AF4A-065606069E85}”主键删除;
3、打开注册表:HKEY_LOCAL_MACHINE\SOFTWARE\TEC\OCULAR.3\SERVER,将“SERVER”主键删除;
4、打开系统盘Windows目录下的win.ini文件,将“[OSERVER3]”及以下内容全部删除,删除前先备份;
5、重新启动OServer3服务,方法:右击任务栏的“服务控制器”,选择“启动服务”
6、重新注册输入相应客户端序列号。
7、运行“通用破解工具.exe”选软件名称为“威盾” 接着选好版本号,我们是3.50 0918  然后左边选进程名称“oserver3.exe”点“先点我测试”一般是成功的,再接着左边选进程名称“ocontrol3.exe”点“先点我测试”一般也是成功的,如果不成功联系我- -
8、同第3点的选择,分别选“oserver3.exe”和“ocontrol3.exe”分别点读取和修改。然后点设置,软件名选威盾,版本号选3.50 0918 在服务方式和多文件都打上勾。文件列表的2个文件也必须有勾(默认是有的)最后点执行 他会问你是否写入启动项,选是。
9、如果顺利到这里为止那么内存破解是已经完成了,但是重新启动系统后又要重新破解一次,我们来解决这个问题。因为此内存破解是必须优先于ipg服务端启动,也就是说破解服务必须先启动,然后在30秒内IPG服务端启动,正好破解。如果ipg服务端先启动,或者两者间隔时间太长,均会破解无效。
10、我们安装“startdelay_v2.3b130.exe”装完后是英文的- -。。好吧,英文不行的,点language选简体中文即可。在里面你可以找到所有的启动项,其中ZLJ是破解程序,via contro v3服务控制器是IPG的服务端。双击VIA contro v3在延迟那里修改时间,建议5-30秒之间,最好自己多测试几次,我的服务器设置为10秒,刚好。。。其他的无须修改。然后点保存。之后他会问你是不是需要开启启动图形显示,开启吧,你会更加一目了然。
11、一直到你测试到重新启动,或关机开机,都能自动破解,那么恭喜你,ipgv3.5 你已经完美破解了。
12、以下是给服务器要连外网的朋友的建议
①hosts文件要修改,修改hosts文件时,试试将  “ “解析为一个本地不存在的IP,如本地IP段为192.168.0.X时,你将上述网址设置为192.168.100.X,修改hosts文件的方法请百度或谷歌。
②“封锁威盾出外网的批处理.bat”文件要运行。。。
③还觉得不保险,就在断网状态下用sniffer抓下包,看ipg对外网联系的是什么ip,什么地址。。找到后怎么办,就不用我说了。
以上各软件是从不同的地方归纳收集而来,在这里要感谢,阳光驿站的K大(虽然我不认识他,但破解工具毕竟是人家做的),网管联盟群的常州-排骨(提供了原版程序,网上已经下不到了)。感谢网管联盟其他群员的大力支持。请转载的也留下这部分信息,毕竟包含了很多人的汗水。。。。


8、启用外网网卡

9、重启服务器

10、查看破解效果
关于破解版软件可以去我们淘宝店进行购买吧!

]]>
生活趣事/post/ipguard.html#comment//feed.asp?cmt=445/cmd.asp?act=tb&id=445&key=bcc748e5
公司助理在东莞好友网络科技工作一个月总结 guoguilin88@163.com (admin)/post/wzyzj.htmlFri, 09 Aug 2013 11:06:27 +0800/post/wzyzj.html      在东莞好友网络科技工作一个月总结
       我在从2013年2月22日到3月22日在东莞东莞好友网络科技做电子商务助理的工作,在这一个月当中,我学到了很多的东西。以前我是做网络销售的,只知道通过网络平台跟客户谈生意,闲暇时做一些推广,但在seo方面了解的不够深入和彻底。在这里来之后,我虚心的向同事们请教seo的优化方面的知识,了解公司的主要产品。通过几次的培训让我知道b2b信息的发布规则,什么样的信息能让百度快速的收录,关键词该怎样组合等等。我将郭经理讲述的内容和我所懂的知识结合在一起,更好的履行作为一名电子商务助理的职责。
      
      在东莞好友网络科技工作了一个月也发现了公司在电子商务不足。做电子商务本身就很枯燥,留住员工的心才是最重要的。所以公司采用培训机制和互相学习机制这个真的很有作用!      做了一个月我对上司,对公司充满了信心,在以后的日子会更加努力做好自己的工作。

                                                                2013年3月22日

]]>
生活趣事/post/wzyzj.html#comment//feed.asp?cmt=443/cmd.asp?act=tb&id=443&key=b21a2818
今天自己做centos服务器:centOS的yum命令的学习教材 guoguimu@163.com (小郭)/post/yum.htmlWed, 27 Mar 2013 14:13:18 +0800/post/yum.htmlcentOS的yum命令详解1.列出所有可更新的软件清单
命令:yum check-update

2.安装所有更新软件
命令:yum update

3.仅安装指定的软件
命令:yum install <package_name>

4.仅更新指定的软件
命令:yum update <package_name>

5.列出所有可安裝的软件清单
命令:yum list

用YUM安装删除软件
装了系统添加删除软件是常事,yum同样可以胜任这一任务,只要软件是rpm安装的。
安装的命令是,yum install xxx,yum会查询数据库,有无这一软件包,如果有,则检查其依赖冲突关系,如果没有依赖冲突,那么最好,下载安装;如果有,则会给出提示,询问是否要同时安装依赖,或删除冲突的包,你可以自己作出判断。
删除的命令是,yum remove xxx,同安装一样,yum也会查询数据库,给出解决依赖关系的提示。


1.用YUM安装软件包
命令:yum install <package_name>

2.用YUM删除软件包
命令:yum remove <package_name>

用YUM查询软件信息
我 们常会碰到这样的情况,想要安装一个软件,只知道它和某方面有关,但又不能确切知道它的名字。这时yum的查询功能就起作用了。你可以用 yum search keyword这样的命令来进行搜索,比如我们要则安装一 个Instant Messenger,但又不知到底有哪些,这时不妨用 yum search messenger这样的指令进行搜索,yum会搜索所有可用rpm的描述,列出所有描述中和messeger有关的rpm包,于 是我们可能得到gaim,kopete等等,并从中选择。
有时我们还会碰到安装了一个包,但又不知道其用途,我们可以用yum info packagename这个指令来获取信息。


1.使用YUM查找软件包
命令:yum search <keyword>

2.列出所有可安装的软件包
命令:yum list

3.列出所有可更新的软件包
命令:yum list updates

4.列出所有已安装的软件包
命令:yum list installed

5.列出所有已安装但不在 Yum Repository 內的软件包
命令:yum list extras

6.列出所指定的软件包
命令:yum list <package_name>

7.使用YUM获取软件包信息
命令:yum info <package_name>

8.列出所有软件包的信息
命令:yum info

9.列出所有可更新的软件包信息
命令:yum info updates

10.列出所有已安裝的软件包信息
命令:yum info installed

11.列出所有已安裝但不在 Yum Repository 內的软件包信息
命令:yum info extras

12.列出软件包提供哪些文件
命令:yum provides <package_name>

清除YUM缓存
yum 会把下载的软件包和header存储在cache中,而不会自动删除。如果我们觉得它们占用了磁盘空间,可以使用yum clean指令进行清除,更精确 的用法是yum clean headers清除header,yum clean packages清除下载的rpm包,yum clean all一 股脑儿端


1.清除缓存目录(/var/cache/yum)下的软件包
命令:yum clean packages

2.清除缓存目录(/var/cache/yum)下的 headers
命令:yum clean headers

3.清除缓存目录(/var/cache/yum)下旧的 headers
命令:yum clean oldheaders

4.清除缓存目录(/var/cache/yum)下的软件包及旧的headers
命令:yum clean, yum clean all (= yum clean packages; yum clean oldheaders)

PS::
fedora/centos系统更新时,由于国内没好的服务器,速度非常慢

给yum安装yum-fastestmirror插件后速度非常快,比平时下载东西还快。

插件安装:
yum install -y yum-fastestmirror

OK,如果下载某个东西时比较慢,就用ctrl+c取消一下,选择自己满意的速度。
试试吧!

]]>
生活趣事/post/yum.html#comment//feed.asp?cmt=436/cmd.asp?act=tb&id=436&key=024808bf
公司要自己架设web服务器,没办法自己操刀吧!CentOS 6.4安装配置LAMP服务器(Apache+PHP5+MySQL) guoguimu@163.com (小郭)/post/webserver.htmlWed, 27 Mar 2013 14:09:06 +0800/post/webserver.html公司要自己架设web服务器,没办法自己操刀吧!CentOS 6.4安装配置LAMP服务器(Apache+PHP5+MySQL)准备篇:

1、配置防火墙,开启80端口、3306端口
vi /etc/sysconfig/iptables
-A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT #允许80端口通过防火墙
-A INPUT -m state --state NEW -m tcp -p tcp --dport 3306 -j ACCEPT #允许3306端口通过防火墙

备注:很多网友把这两条规则添加到防火墙配置的最后一行,导致防火墙启动失败,

正确的应该是添加到默认的22端口这条规则的下面

如下所示:

好友网络小郭 温馨提醒:www.gdhaoyou.com原创内容版权所有,转载请注明出处及原文链接
########################################################
# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 3306 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT
########################################################

/etc/init.d/iptables restart #重启防火墙使配置生效

2、关闭SELINUX
vi /etc/selinux/config
#SELINUX=enforcing #注释掉
#SELINUXTYPE=targeted #注释掉
SELINUX=disabled #增加
:wq!#保存退出
shutdown -r now#重启系统

安装篇:

一、安装Apache
yum install httpd #根据提示,输入Y安装即可成功安装
/etc/init.d/httpd start#启动Apache
备注:Apache启动之后会提示错误:
正在启动 httpd:httpd: Could not reliably determine the server's fully qualif domain name, using ::1 for ServerName
解决办法:
vi /etc/httpd/conf/httpd.conf #编辑
找到 #ServerName www.example.com:80
修改为 ServerName www.gdhaoyou.com:80 #这里设置为你自己的域名,如果没有域名,可以设置为localhost
:wq! #保存退出
chkconfig httpd on #设为开机启动
/etc/init.d/httpd restart #重启Apache

二、安装MySQL

1、安装MySQL
yum install mysql mysql-server #询问是否要安装,输入Y即可自动安装,直到安装完成
/etc/init.d/mysqld start #启动MySQL
chkconfig mysqld on #设为开机启动
cp /usr/share/mysql/my-medium.cnf /etc/my.cnf #拷贝配置文件(注意:如果/etc目录下面默认有一个my.cnf,直接覆盖即可)

2、为root账户设置密码
mysql_secure_installation
回车,根据提示输入Y
输入2次密码,回车
根据提示一路输入Y
最后出现:Thanks for using MySQL!
MySql密码设置完成,重新启动 MySQL:
/etc/init.d/mysqld restart #重启
/etc/init.d/mysqld stop #停止
/etc/init.d/mysqld start #启动

三、安装PHP5

1、安装PHP5

好友网络小郭 温馨提醒:www.gdhaoyou.com原创内容版权所有,转载请注明出处及原文链接
yum install php #根据提示输入Y直到安装完成

2、安装PHP组件,使 PHP5 支持 MySQL
yum install php-mysql php-gd libjpeg* php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc php-mbstring php-mcrypt php-bcmath php-mhash libmcrypt #这里选择以上安装包进行安装,根据提示输入Y回车
/etc/init.d/mysqld restart #重启MySql
/etc/init.d/httpd restart #重启Apche

配置篇

一、Apache配置
vi /etc/httpd/conf/httpd.conf #编辑文件
ServerTokens OS  #在44行 修改为:ServerTokens Prod (在出现错误页的时候不显示服务器操作系统的名称)
ServerSignature On  #在536行 修改为:ServerSignature Off (在错误页中不显示Apache的版本)
Options Indexes FollowSymLinks  #在331行 修改为:Options Includes ExecCGI FollowSymLinks(允许服务器执行CGI及SSI,禁止列出目录)
#AddHandler cgi-script .cgi #在796行 修改为:AddHandler cgi-script .cgi .pl (允许扩展名为.pl的CGI脚本运行)
AllowOverride None  #在338行 修改为:AllowOverride All (允许.htaccess)
AddDefaultCharset utf-8 #在759行 修改为:AddDefaultCharset GB2312 (添加GB2312为默认编码)
  Options Indexes MultiViews FollowSymLinks #在554行 修改为 Options MultiViews FollowSymLinks(不在浏览器上显示树状目录结构)
DirectoryIndex index.html index.html.var #在402行 修改为:DirectoryIndex index.html index.htm Default.html Default.htm index.php Default.php index.html.var (设置默认首页文件,增加index.php)
KeepAlive Off #在76行 修改为:KeepAlive On (允许程序性联机)
MaxKeepAliveRequests 100 #在83行 修改为:MaxKeepAliveRequests 1000 (增加同时连接数)
:wq! #保存退出
/etc/init.d/httpd restart#重启
好友网络小郭 温馨提醒:www.gdhaoyou.com原创内容版权所有,转载请注明出处及原文链接
rm -f /etc/httpd/conf.d/welcome.conf /var/www/error/noindex.html #删除默认测试页

二、php配置
vi /etc/php.ini #编辑
date.timezone = PRC #在946行 把前面的分号去掉,改为date.timezone = PRC
disable_functions = passthru,exec,system,chroot,scandir,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server,escapeshellcmd,dll,popen,disk_free_space,checkdnsrr,checkdnsrr,getservbyname,getservbyport,disk_total_space,posix_ctermid,posix_get_last_error,posix_getcwd, posix_getegid,posix_geteuid,posix_getgid, posix_getgrgid,posix_getgrnam,posix_getgroups,posix_getlogin,posix_getpgid,posix_getpgrp,posix_getpid, posix_getppid,posix_getpwnam,posix_getpwuid, posix_getrlimit, posix_getsid,posix_getuid,posix_isatty, posix_kill,posix_mkfifo,posix_setegid,posix_seteuid,posix_setgid, posix_setpgid,posix_setsid,posix_setuid,posix_strerror,posix_times,posix_ttyname,posix_uname
#在386行 列出PHP可以禁用的函数,如果某些程序需要用到这个函数,可以删除,取消禁用。
expose_php = Off #在432行 禁止显示php版本的信息
magic_quotes_gpc = On #在745行 打开magic_quotes_gpc来防止SQL注入
short_open_tag = ON #在229行支持php短标签
open_basedir = .:/tmp/ #在380行 设置表示允许访问当前目录(即PHP脚本文件所在之目录)和/tmp/目录,可以防止php木马跨站,如果改了之后安装程序有问题,可以注销此行,或者直接写上程序的目录/data/www.osyunwei.com/:/tmp/
:wq! #保存退出
/etc/init.d/mysqld restart #重启MySql
/etc/init.d/httpd restart #重启Apche

测试篇
cd /var/www/html
vi index.php #编辑输入下面内容
<?php
phpinfo();
?>
:wq! #保存退出
在客户端浏览器输入服务器IP地址,可以看到相关的配置信息!
好友网络小郭 温馨提醒:www.gdhaoyou.com原创内容版权所有,转载请注明出处及原文链接

注意:apache默认的程序目录是/var/www/html
权限设置:chown apache.apache -R /var/www/html
至此,CentOS 6.3安装配置LAMP服务器(Apache+PHP5+MySQL)完成

 

]]>
生活趣事/post/webserver.html#comment//feed.asp?cmt=435/cmd.asp?act=tb&id=435&key=2da1c7dc